Zen Cart v1.5.4 has been released. According to Zen Cart, v1.5.4 has undergone PA-DSS certification, and the paperwork is awaiting a final review by the PCI SSC, before being listed on their site by the end of January.
The changes within are not what we expected entirely… In fact there are a bunch of changes that will cause plugins and customizations to require additional work to implement.
Our stand and suggestion as a company is as follows:
- Plan on Rip and Rebuilding your Zen Cart instead of attempting to upgrade, especially if you are running Zen Cart 1.3.X.
- If you are running Zen Cart 1.5.1 or better, you might consider waiting until certification is completed and plugins/modules are updated.
Zen Cart v1.5.4 requires a minimum of the following:
Zen Cart v1.5.4 is compatible with PHP 5.2.10 through PHP 5.6, and MySQL 5.1 thru 5.6
Note: security features are stronger when using PHP 5.3.7 or newer.
Note: PHP 5.2.x and PHP 5.3.x are deprecated and no longer supported by the PHP project. You REALLY should be using PHP 5.5 if possible, for both security and speed benefits.
MySQL 5.1 or higher
Apache 2.0 or higher.
Apache configured with AllowOverride set to either 'All' or at least both 'Limit' and 'Indexes' parameters, and preferably the 'Options' parameter as well.
PHP configured to support CURL with OpenSSL